[Solved] Magento 2.3 Upgrade issue

treyBake Asks: Magento 2.3 Upgrade issue
I’m trying to upgrade to Magento 2.3.1 and I’m running into a problem. I was on PHP 7.1.3 and noticed in the system requirements that it requires 7.1.3 and 7.2.X. We’ve upgraded the server PHP version to 7.2.16.

Running composer update after doing the other steps brings up this error:

Code:
[user@machine public_html]$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 138 installs, 163 updates, 0 removals
  - Installing magento/inventory-composer-installer (1.1.0): Loading from cache

Warning: Unsupported declare 'strict_types' in /home/site/public_html/vendor/magento/inventory-composer-installer/src/Plugin.php on line 6

Parse error: syntax error, unexpected ':', expecting ';' or '{' in /home/site/public_html/vendor/magento/inventory-composer-installer/src/Plugin.php on line 55

Running $ php -v returns this info:

Code:
[user@machine public_html]$ php -v
PHP 7.2.16 (cli) (built: Mar 25 2019 18:26:43) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

and in my composer.json I have:

Code:
... etc ...
"config": {
    "platform": {
        "php": "7.2.16"
    },
    "use-include-path": true
},
... etc ...

I’ve scoured the internet and it all leads back to upgrade PHP version – which … it is. What step am I missing?

edit​

question replies​

Are you following the steps outlined in the Magento DevDocs or another resource? – Did you update using the Magento script at Upgrade Commerce | Adobe Commerce Developer Guide?

following the steps for manual CLI upgrade.

Do you have a cache storage system like Redis or Memcached that needs to be cleared?

Nope.

Do you have any other errors if you disable the inventory-composer-installer module?

nope.

Are you upgrading php-fpm?

Not using it.

What version of Composer do you have after upgrading?

composer -V shows

Composer version 1.5.2 2017-09-11 16:59:25

Ten-tools.com may not be responsible for the answers or solutions given to any question asked by the users. All Answers or responses are user generated answers and we do not have proof of its validity or correctness. Please vote for the answer that helped you in order to help others find out which is the most helpful answer. Questions labeled as solved may be solved or may not be solved depending on the type of question and the date posted for some posts may be scheduled to be deleted periodically. Do not hesitate to share your response here to help other visitors like you. Thank you, Ten-tools.