[Solved] Fail to yum install libstdc++.so.6 when installing db2 v11.5 in redhat OS

Panadol Chong Asks: Fail to yum install libstdc++.so.6 when installing db2 v11.5 in redhat OS
Good day,

I am trying to install DB2 V11.5 (64 bit) in red hat OS.

However, I having some warning message as follow:

Code:
Summary of prerequisites that are not met on the current system:

   DBT3514W  The db2prereqcheck utility failed to find the following 32-bit library file: "/lib/libpam.so*".

DBT3514W  The db2prereqcheck utility failed to find the following 32-bit library file: "libstdc++.so.6".

Then I go to do yum install libstdc++.i686, but hitting another error which is as follow:
enter image description here

Not understand that why the system hitting 32 bit error when I am installing 64 bits DB2. And My OS is redhat 64 bits:
enter image description here

Kindly advise how can I continue to fix this issue? Edit ** I downloaded the db2 v11.5 from IBM website, the file name will be as follow: DB2_Svr_11.5_Linux_x86-64.tar

Ten-tools.com may not be responsible for the answers or solutions given to any question asked by the users. All Answers or responses are user generated answers and we do not have proof of its validity or correctness. Please vote for the answer that helped you in order to help others find out which is the most helpful answer. Questions labeled as solved may be solved or may not be solved depending on the type of question and the date posted for some posts may be scheduled to be deleted periodically. Do not hesitate to share your response here to help other visitors like you. Thank you, Ten-tools.